易语言节点删除重复源码

生成重复元素

1、我们采用变量循环,在取随机数时,极值为5,而变量循环的起始值和结束值加大,这样必然产生重复的元素

.版本 2
 
.局部变量 i, 整数型
.变量循环首 (1, 16, 1, i)
    列表框1.加入项目 (字符 (取随机数 (65, 70)), )
.变量循环尾 ()

2、通过节点加入属性,把列表框里的值分别加入节点,然后通过节点.取全部属性名 (文本数组)赋给文本数组
3、遍历文本数组,加入列表框

.版本 2
.支持库 EDataStructure
 
.子程序 _按钮1_被单击
.局部变量 节点, 节点
.局部变量 i, 整数型
.局部变量 文本数组, 文本型, , "0"
 
.变量循环首 (0, 列表框1.取项目数 ()1, 1, i)
    节点.加入属性 (列表框1.取项目文本 (i), “”)
.变量循环尾 ()
节点.取全部属性名 (文本数组)
列表框1.清空 ()
.变量循环首 (1, 取数组成员数 (文本数组), 1, i)
    列表框1.加入项目 (文本数组 [i], )
.变量循环尾 ()

发布日期:

所属分类: 易语言 标签: