第14课易语言大漠组合框列表选项一键登录

源码:

.版本 2
.支持库 dp1
 
.子程序 _组合框1_列表项被选择
.局部变量 z_name, 文本型
.局部变量 word, 文本型
.局部变量 w_array, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 s_array, 文本型, , "0"
.局部变量 name, 文本型
.局部变量 passd, 文本型
.局部变量 pass, 字节集
 
' 要读取文本zhm.txt里面的账号和密码,和z_name对应的密码
z_name = 组合框1.取项目文本 (组合框1.现行选中项)
word = 到文本 (读入文件 (取运行目录 () + “\zhm.txt”))
w_array = 分割文本 (word, #换行符, )
.计次循环首 (取数组成员数 (w_array), i)
    s_array = 分割文本 (w_array [i], “|”, )
    name = s_array [1]
    passd = s_array [2]
    .如果 (z_name = name)
        账号 = name
        pass = 解密数据 (到字节集 (passd), “2”, 1)
        密码 = 到文本 (pass)
 
    .否则
 
    .如果结束
 
.计次循环尾 ()
' 开始一键登录
启动游戏 ()
绑定游戏 ()
开始游戏 ()
选择服务器 ()
输入账号密码 (账号, 密码)
判断单选框 ()
选择角色 (位置变量)


发布日期:

所属分类: 易语言 标签: