易语言调用对象执行外部程序源码

窗口组件:
1、通用对话框,
2、编辑框
源码:

.版本 2
 
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
 
.子程序 执行程序
.参数 地址, 文本型
.局部变量 WshEll, 对象
 
WshEll.创建 (“WScript.Shell, )
WshEll.方法 (“Run”, 地址)
WshEll.清除 ()
 
.子程序 _按钮1_被单击
 
通用对话框1.打开 ()
.如果真 (通用对话框1.文件名 ≠ “”)
    编辑框1.内容 = 通用对话框1.文件名
.如果真结束
 
.子程序 _按钮2_被单击
 
.如果真 (文件是否存在 (编辑框1.内容) = 真)
    执行程序 (编辑框1.内容)
.如果真结束

发布日期:

所属分类: 易语言 标签: