易语言多线程API综合应用实战

1、纠错 进程_ID取窗口句柄

窗口_句柄取线程程ID 改成 窗口_句柄取进程ID

511遇见易语言大漠游戏外挂综合教程-多线程模块制作
第九课:第九课511遇见易语言大漠模块制作API进程_ID取窗口句柄http://v.youku.com/v_show/id_XMjcwMjMwNDk3Ng==.html
2、API IsWindowVisible 返回值 整数型 改成:逻辑型

多线程API 综合应用举例

1、进程_取ID数组
2、进程_ID取窗口句柄
3、窗口_取标题
4、窗口_取类名
5、超级列表框
6、高级表格

超级列表框源码

.版本 2
.支持库 iext

.子程序 _按钮1_被单击, , , 超级列表框
.局部变量 进程ID数组, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 索引, 整数型
.局部变量 窗口句柄, 整数型
.局部变量 窗口标题, 文本型
.局部变量 窗口类名, 文本型

超级列表框1.全部删除 ()
进程_取ID数组 (“gamefree.exe”, 进程ID数组, )
.计次循环首 (取数组成员数 (进程ID数组), i)
索引 = 超级列表框1.插入表项 (, , , , , )
窗口句柄 = 进程_ID取窗口句柄 (进程ID数组 [i], , , )
窗口标题 = 窗口_取标题 (窗口句柄)
窗口类名 = 窗口_取类名 (窗口句柄)
超级列表框1.置标题 (索引, 0, 到文本 (i))
超级列表框1.置标题 (索引, 1, 窗口类名)
超级列表框1.置标题 (索引, 2, 窗口标题)
超级列表框1.置标题 (索引, 3, 到文本 (窗口句柄))
超级列表框1.置标题 (索引, 4, 到文本 (进程ID数组 [i]))
.计次循环尾 ()

高级表格源码

.版本 2
.支持库 eGrid

.子程序 _按钮2_被单击, , , 高级表格
.局部变量 进程ID数组, 整数型, , "0"
.局部变量 i, 整数型
.局部变量 窗口句柄, 整数型
.局部变量 窗口标题, 文本型
.局部变量 局_窗口类名, 文本型

高级表格1.行数 = 1
高级表格1.列数 = 1
.计次循环首 (4, )
高级表格1.插入列 (, )
高级表格1.置数据 (0, 0, 1, “序列”)
高级表格1.置列宽 (1, 80)
高级表格1.置数据 (0, 1, 1, “类名”)
高级表格1.置列宽 (2, 120)
高级表格1.置数据 (0, 2, 1, “标题”)
高级表格1.置列宽 (3, 80)
高级表格1.置数据 (0, 3, 1, “窗口句柄”)
高级表格1.置列宽 (4, 80)
高级表格1.置数据 (0, 4, 1, “进程ID”)
高级表格1.置列宽 (5, 80)
.计次循环尾 ()
进程_取ID数组 (“gamefree.exe”, 进程ID数组, )
.计次循环首 (取数组成员数 (进程ID数组), i)
高级表格1.插入行 (, )
窗口句柄 = 进程_ID取窗口句柄 (进程ID数组 [i], , , )
窗口标题 = 窗口_取标题 (窗口句柄)
局_窗口类名 = 窗口_取类名 (窗口句柄)
高级表格1.置数据 (i, 0, 1, 到文本 (i))
高级表格1.置数据 (i, 1, 1, 局_窗口类名)
高级表格1.置数据 (i, 2, 1, 窗口标题)
高级表格1.置数据 (i, 3, 1, 窗口句柄)
高级表格1.置数据 (i, 4, 1, 进程ID数组 [i])
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: