511遇见易语言多线程大漠多线程-26-免注册多线程程序集模块制作方法1

模块源码:

.版本 2

.程序集 集多线程
.程序集变量 obj, 对象, , "100"

.子程序 插件释放, 逻辑型, 公开, 返回假收费注册失败
.参数 插件路径, 文本型, 可空
.参数 是否收费, 逻辑型, 可空, 为空为加免费

.判断开始 (是否收费 = 真)
创建目录 (#路径)
置文件属性 (#路径, 2 + 4 + 32)
写到文件 (#路径 + “\dm71830.dll”, #dm71830)
置文件属性 (#路径 + “\dm71830.dll”, 2 + 4 + 32)
动态调用插件 (#路径 + “\dm71830.dll”)
.判断 (是否收费 = 假 且 是否为空 (插件路径))
创建目录 (#路径)
置文件属性 (#路径, 2 + 4 + 32)
写到文件 (#路径 + “\dm31233.dll”, #dm31233)
置文件属性 (#路径 + “\dm31233.dll”, 2 + 4 + 32)
动态调用插件 (#路径 + “\dm31233.dll”)

.判断 (是否为空 (插件路径) = 假)
动态调用插件 (插件路径)
.默认

.判断结束

.子程序 插件创建, , 公开, 每一个线程都要创建大漠对象
.参数 索引, 整数型

obj [索引].清除 ()
obj [索引].创建 (“dm.dmsoft”, )

.子程序 DownCpu, 整数型, 公开
.参数 rate, 整数型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“DownCpu”, rate))

.子程序 释放, , 公开
.参数 索引, 整数型

obj [索引].清除 ()

.子程序 BindWindow, 整数型, 公开
.参数 hwnd, 整数型
.参数 display, 文本型
.参数 mouse, 文本型
.参数 keypad, 文本型
.参数 mode, 整数型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“BindWindow”, hwnd, display, mouse, keypad, mode))

.子程序 UnBindWindow, 整数型, 公开
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“UnBindWindow”, ))

.子程序 KeyPress, 整数型, 公开
.参数 vk, 整数型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“KeyPress”, vk))

.子程序 Reg, 整数型, 公开
.参数 code, 文本型
.参数 Ver, 文本型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“Reg”, code, Ver))

.子程序 SetPath, 整数型, 公开
.参数 path, 文本型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“SetPath”, path))

.子程序 SetDict, 整数型, 公开
.参数 index, 整数型
.参数 dict_name, 文本型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“SetDict”, index, dict_name))

.子程序 EnableShareDict, 整数型, 公开, 允许当前调用的对象使用全局字库
.参数 en, 整数型
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“EnableShareDict”, en))

.子程序 SetShowErrorMsg, , 公开, 设置是否弹出错误信息,默认是打开.
.参数 show, 整数型, , 0表示不打开,1表示打开
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“SetShowErrorMsg”, show))

.子程序 SetParam64ToPointer, 整数型, 公开
.参数 索引, 整数型

返回 (obj [索引].数值方法 (“SetParam64ToPointer”, ))


发布日期:

所属分类: 易语言 标签: