511遇见易语言多线程大漠多线程-27免注册多线程程序集模块-调用实例1

教程源码:

.版本 2

.子程序 __启动窗口_创建完毕

' 释放大漠插件一次,演示的免费的3.1233
插件释放 (, )
' 插件大漠对象一下
' 插件创建 (1)
' 注册大漠
' Reg (“akdjsfaksdjflkasjlkd”, , 1)

.子程序 _按钮3_被单击
.局部变量 i

.如果 (进程_取ID数组 (“gamefree.exe”, 进程ID数组, ) = 0)
信息框 (“请开启游戏”, 0, , )
.否则

.如果结束
游戏窗口数量 = 取数组成员数 (进程ID数组)
重定义数组 (hwnd, 假, 游戏窗口数量)

.计次循环首 (取数组成员数 (进程ID数组), i)
系统处理事件 ()
' 初始化当前线程COM组件为MTA模式
初始化COM库MAT ()
' 创建大漠对象,每个线程都有创建一次
插件创建 (i)
' 可以设置一下初始化的东西
SetParam64ToPointer (i)
' 设置全局路径
' SetPath (取运行目录 (), i)
' 字库相关设置
' EnableShareDict (1, i)
' SetDict (0, “1.txt”, i)
' 屏蔽一下错误弹框
' enables

' 获取游戏窗口句柄
hwnd [i] = 进程_ID取窗口句柄 (进程ID数组 [i], , , )
.如果真 (BindWindow (hwnd [i], “dx”, “dx2”, “windows”, 0, i) = 1)
超级延时 (1000, )
' 降低CPU
DownCpu (40, i)
dm_n = i
' 启动线程 (, , )
线程_启动 (&工作线程, i, )
' 加一点时间差片段
超级延时 (10, )

.如果真结束

.计次循环尾 ()

.子程序 工作线程
.局部变量 number, 整数型

许可证 = 线程_创建许可证 ()
线程_进入许可区 (许可证)
线程_初始化COM库 ()

number = dm_n

跑路 (number)
对话 (number)
打怪 (number)

' 解除绑定
UnBindWindow (number)
' 销毁对象
释放 (number)

线程_取消COM库 ()
线程_退出许可区 (许可证)
线程_删除许可证 (许可证)


发布日期:

所属分类: 后端


下一篇:

没有了,已经是最新文章