511遇见易语言多线程大漠多线程-25大漠免注册程序集模块制作方法

模块源码:

.版本 2

.程序集 集_单线程
.程序集变量 obj, 对象

.子程序 初始化插件, 逻辑型, 公开, 成功返回真
.参数 是否收费版, 逻辑型, 可空, 为空免费

创建目录 (取运行目录 () + “\game”)
置文件属性 (取运行目录 () + “\game”, 2 + 4)
写到文件 (取运行目录 () + “\game\greg.dll”, #dmmreg)
置文件属性 (取运行目录 () + “\game\greg.dll”, 2 + 4)
CoInitialize (0)
.判断开始 (是否收费版)
写到文件 (取运行目录 () + “\game\dmsf.dll”, #dmsf)
置文件属性 (取运行目录 () + “\game\dmsf.dll”, 2 + 4 + 32)
SetDllPathA (取运行目录 () + “\game\dmsf.dll”, 0)

.默认
写到文件 (取运行目录 () + “\game\dmmf.dll”, #dmmf)
置文件属性 (取运行目录 () + “\game\dmmf.dll”, 2 + 4 + 32)
SetDllPathA (取运行目录 () + “\game\dmmf.dll”, 0)

.判断结束

创建 ()
.判断开始 (Ver () = “3.1233”)
输出调试文本 (“免费版3.1233”)
返回 (真)
.判断 (Ver () = “7.1830”)
输出调试文本 (“收费版7.1830”)
返回 (真)
.默认
输出调试文本 (“插件创建对象失败”)
返回 (假)
.判断结束

.子程序 创建, , 公开

释放 ()
obj.创建 (“dm.dmsoft”, )
SetParam64ToPointer ()

.子程序 释放, , 公开

obj.清除 ()


发布日期:

所属分类: 易语言 标签: