易语言教程磁盘操作取磁盘空间相关实例

视频教程源码

.版本 2
.支持库 eAPI
.支持库 iext
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 __启动窗口_创建完毕
.局部变量 A, 文本型, , "0"
.局部变量 B
.局部变量 i, 整数型
.局部变量 盘符, 文本型
.局部变量 卷标, 文本型
.局部变量 总空间, 双精度小数型
.局部变量 剩余空间, 双精度小数型
.局部变量 索引

' 0、#接口常量.所有驱动器;1、#接口常量.硬盘驱动器;2、#接口常量.光盘驱动器;3、#接口常量.可移动驱动器;4、#接口常量.网络驱动器。
A = 取驱动器列表 (#接口常量.硬盘驱动器)
B = 取数组成员数 (A)
.计次循环首 (B, i)
索引 = 超级列表框1.插入表项 (, , , , , )
盘符 = A [i]
总空间 = 取磁盘总空间 (A [i])
剩余空间 = 取磁盘剩余空间 (A [i])
卷标 = 取磁盘卷标 (A [i])
' 换算
总空间 = 四舍五入 (总空间 ÷ 1024 ÷ 1024, 0)
剩余空间 = 四舍五入 (剩余空间 ÷ 1024 ÷ 1024, 1)
调试输出 (剩余空间)
' 写入超级列表框
超级列表框1.置标题 (索引, 0, 盘符)
超级列表框1.置标题 (索引, 1, 卷标)
超级列表框1.置标题 (索引, 2, 到文本 (总空间) + “ GB”)
超级列表框1.置标题 (索引, 3, 到文本 (剩余空间) + “ GB”)
.计次循环尾 ()
_驱动器框1_驱动器被改变 ()

.子程序 _驱动器框1_驱动器被改变
.局部变量 盘符, 文本型
.局部变量 卷标, 文本型
.局部变量 总空间, 双精度小数型
.局部变量 剩余空间, 双精度小数型

进度条1.位置 = 1000
盘符 = 驱动器框1.驱动器
总空间 = 取磁盘总空间 (盘符)
剩余空间 = 取磁盘剩余空间 (盘符)
卷标 = 取磁盘卷标 (盘符)
' 换算
总空间 = 四舍五入 (总空间 ÷ 1024 ÷ 1024, 0)
剩余空间 = 四舍五入 (剩余空间 ÷ 1024 ÷ 1024, 1)
进度条1.位置 = 进度条1.位置 - 剩余空间 ÷ 总空间 × 进度条1.位置

标签1.标题 = 卷标 + “ (” + 盘符 + “:)” + 到文本 (剩余空间) + “ GB可用,共” + 到文本 (总空间) + “GB”


发布日期:

所属分类: 易语言 标签: