易语言API模块制作cmd移动并运行文件

视频教程源码

.版本 2

.子程序 cmd_移动并运行, , 公开, cmd移动文件并运行这个文件
.参数 要移动的文件名, 文本型, , 要移动文件的全路径
.参数 移动到的目录名, 文本型, , 移动后的目录
.局部变量 t_fname, 文本型, , , 临时文件名
.局部变量 t_temp, 文本型

t_fname = 文件_取文件名 (要移动的文件名, 真)
t_temp = #移动并运行bat
t_temp = 子文本替换 (t_temp, “被移动的文件”, 要移动的文件名, , , 真)
t_temp = 子文本替换 (t_temp, “目录”, 移动到的目录名, , , 真)
t_fname = 移动到的目录名 + “\” + t_fname
t_temp = 子文本替换 (t_temp, “要运行的文件”, t_fname, , , 真)
写到文件 (取运行目录 () + “\123.bat”, 到字节集 (t_temp))
运行 (取运行目录 () + “\123.bat”, 假, #隐藏窗口)


发布日期:

所属分类: 易语言 标签: