易语言PathRelativePathToA关联路径

关联路径PathRelativePathToA

.版本 2
 
.DLL命令 关联路径_, 整数型, "shlwapi.dll", "PathRelativePathToA"
    .参数 缓冲区文本, 文本型, , pszPath
    .参数 源路径, 文本型, , pszFrom
    .参数 源属性标志, 整数型, , dwAttrFrom
    .参数 目标路径, 文本型, , pszTo
    .参数 目标属性标志, 整数型, , dwAttrTo

易语言调用

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
' PathRelativePathToA的作用是Creates a relative path from one file or folder to another。
' 成功返回1,失败返回0。
 
.子程序 _按钮_关联路径_被单击
.局部变量 局部_返回文本, 文本型
.局部变量 局部_路径文本1, 文本型
.局部变量 局部_路径文本2, 文本型
 
局部_返回文本 = 取空白文本 (512)
局部_路径文本1 = 编辑框_路径文本1.内容
局部_路径文本2 = 编辑框_路径文本2.内容
关联路径_ (局部_返回文本, 局部_路径文本1, 16, 局部_路径文本2, 16)
编辑框_返回文本.内容 = 局部_返回文本

发布日期:

所属分类: 易语言 标签: