第二课 C#调用易语言编写的dll

易语言DLL源码:

.版本 2
 
.子程序 add, 整数型, 公开
.参数 x, 整数型
.参数 y, 整数型
 
返回 (x + y)
 
 
.版本 2
 
.子程序 msg, , 公开
.参数 a, 整数型
.参数 b, 整数型
 
信息框 (到文本 (a) + “+” + 到文本 (b) + “=” + 到文本 (a + b), 0, “C#调用易语言Dll”, )

C#调用DLL源码:

using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Windows.Forms;
using System.Runtime.InteropServices;
 
namespace msg
{
    public partial class Form1 : Form
    {
        public Form1()
        {
            InitializeComponent();
        }
        [DllImport("msg.dll")]
        static extern IntPtr msg(int a, int b);
        private void button1_Click(object sender, EventArgs e)
        {
            msg(10, 25);
        }
    }
}

优酷视频链接:


发布日期:

所属分类: 易语言 标签: