易语言api hook CreateFileA

hook 说明

1、未hook前会生成一个111.txt,内容是“1111111111”

写到文件 (取运行目录 () + “\111.txt”, 到字节集 (1111111111))

2、hook后就会转向我们自定义的MyCreateFileA

h.安装Hook (“kernel32”, “CreateFileA”, 到整数 (&MyCreateFileA))
h.开始Hook ()

3、回调函数MyCreateFileA

.版本 2
.子程序 MyCreateFileA, 整数型
.参数 lpFileName, 文本型, , 0//指向文件名的指针
.参数 dwDesiredAccess, 整数型, , 0//访问模式(写/读)
.参数 dwShareMode, 整数型, , 0 //共享模式
.参数 lpSecurityAttributes, 整数型, , 0//指向安全属性的指针
.参数 dwCreationDisposition, 整数型, , 0//如何创建
.参数 dwFlagsAndAttributes, 整数型, , 0 //文件属性
.参数 hTemplateFile, 整数型, , 0//用于复制文件句柄
.局部变量 ret, 整数型
 
h.停止Hook ()
ret = CreateFileA (取运行目录 () + “\999.txt”, dwDesiredAccess, dwShareMode, lpSecurityAttributes, dwCreationDisposition, dwFlagsAndAttributes, hTemplateFile)
h.开始Hook ()
返回 (ret)

这样,就会写出文件999.txt,这样只是修改了文件名称,如果想把内容也hook成我们想要的,那么就需要在回调里加入以下这句:

999.tx

4、回调函数,必须先停止Hook (),最后开始Hook ()

教程获取下载:


发布日期:

所属分类: 易语言 标签: