易语言大漠模块制作截图截图Capture

模块源码

.版本 2

.子程序 Capture, 整数型, 公开, 抓取指定区域(x1, y1, x2, y2)的图像,保存为file(24位位图)(返回值:0失败,1成功)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 file, 文本型, , file 字符串:保存的文件名,保存的地方一般为SetPath中设置的目录当然这里也可以指定全路径名.

返回 (obj.数值方法 (“Capture”, x1, y1, x2, y2, file))

.子程序 CaptureGif, 整数型, 公开, 抓取指定区域(x1, y1, x2, y2)的动画,保存为gif格式(返回值:0失败,1成功)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 file, 文本型, , file 字符串:保存的文件名,保存的地方一般为SetPath中设置的目录当然这里也可以指定全路径名.
.参数 delay, 整数型, , 整形数: 动画间隔,单位毫秒。如果为0,表示只截取静态图片
.参数 time, 整数型, , time 整形数: 总共截取多久的动画,单位毫秒。

返回 (obj.数值方法 (“CaptureGif”, x1, y1, x2, y2, file, delay, time))

.子程序 CaptureJpg, 整数型, 公开, 抓取指定区域(x1, y1, x2, y2)的图像,保存为file(JPG压缩格式)(返回值:0失败,1成功)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 file, 文本型, , file 字符串:保存的文件名,保存的地方一般为SetPath中设置的目录当然这里也可以指定全路径名.
.参数 quality, 整数型, , quality 整形数: jpg压缩比率(1-100) 越大图片质量越好

返回 (obj.数值方法 (“CaptureJpg”, x1, y1, x2, y2, file, quality))

.子程序 CapturePng, 整数型, 公开, 同Capture函数,只是保存的格式为PNG.(返回值:0失败,1成功)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 file, 文本型, , file 字符串:保存的文件名,保存的地方一般为SetPath中设置的目录当然这里也可以指定全路径名.

返回 (obj.数值方法 (“CapturePng”, x1, y1, x2, y2, file))

.子程序 CapturePre, 整数型, 公开, 抓取上次操作的图色区域,保存为file(24位位图)(返回值:0失败,1成功)
.参数 file, 文本型, , file 字符串:保存的文件名,保存的地方一般为SetPath中设置的目录,当然这里也可以指定全路径名.

返回 (obj.数值方法 (“CapturePre”, file))

.子程序 CmpColor, 整数型, 公开, 比较指定坐标点(x,y)的颜色,返回值:(0: 颜色匹配;1: 颜色不匹配)
.参数 x, 整数型, , x 整形数: X坐标
.参数 y, 整数型, , y 整形数: Y坐标
.参数 color, 文本型, , color 字符串: 颜色字符串,可以支持偏色,多色,例如 "ffffff-202020|000000-000000" 这个表示白色偏色为202020,和黑色偏色为000000.颜色最多支持10种颜色组合. 注意,这里只支持RGB颜色.
.参数 sim, 双精度小数型, , sim 双精度浮点数: 相似度(0.1-1.0)

返回 (obj.数值方法 (“CmpColor”, x, y, color, sim))

.子程序 EnableDisplayDebug, 整数型, 公开, 开启图色调试模式,此模式会稍许降低图色和文字识别的速度.默认不开启.(返回值:0失败,1成功)
.参数 enable_debug, 整数型, , enable_debug 整形数: 0 为关闭;1 为开启

返回 (obj.数值方法 (“EnableDisplayDebug”, enable_debug))

.子程序 EnableGetColorByCapture, 整数型, 公开, 允许调用GetColor GetColorBGR GetColorHSV 以及 CmpColor时,以截图的方式来获取颜色。(返回值:0失败,1成功)
.参数 enable, 整数型, , enable 整形数: 0 关闭;1 打开

返回 (obj.数值方法 (“EnableGetColorByCapture”, enable))

测试源码

.版本 2

.子程序 _按钮4_被单击, , , Capture

插件初始化 ()
SetPath (取运行目录 ())
绑定 ()
CapturePng (0, 0, 2000, 2000, “yj.png”)

视频播放链接


发布日期:

所属分类: 易语言 标签: