易语言获取屏幕和客户区鼠标坐标

一、屏幕内鼠标的水平垂直位置
 
1、系统处理
 
取鼠标水平位置()
取鼠标垂直位置()
 
2、API
 
.版本 2
.DLL命令 API_取鼠标位置, 整数型, "user32", "GetCursorPos", , 获取鼠标指针的当前位置  非零表示成功,零表示失败。会设置GetLastError
.参数 位置, POINTAPI, , POINTAPI,随同指针在屏幕像素坐标中的位置载入的一个结构;
 
二、窗口内鼠标的水平垂直位置
 
.DLL命令 API_ScreenToClient, 整数型, "user32", "ScreenToClient", 判断屏幕上一个指定点的客户区坐标 非零表示成功,零表示失败
    .参数 hwnd, 整数型, , 一个窗口的句柄,该窗口定义了要使用的客户区坐标系统
    .参数 lpPoint, POINTAPI, , POINTAPI,屏幕坐标系统中包含了屏幕点的结构。这个函数会随同相应的客户区坐标(由hwnd决定)载入结构;
.数据类型 POINTAPI, 坐标;
    .成员 横向位置, 整数型, , , 
    .成员 纵向位置, 整数型, , ,
  1. .版本 2
  2. .支持库 eAPI
  3.  
  4. .程序集 窗口程序集_启动窗口
  5. .程序集变量 x, 整数型
  6. .程序集变量 y, 整数型
  7. .程序集变量 a, POINTAPI
  8.  
  9. .子程序 _时钟1_周期事件
  10.  
  11. ' 系统自动命令 ()
  12. ' API鼠标位置 ()
  13. 取窗口内坐标 ()
  14.  
  15. .子程序 系统自动命令
  16.  
  17. x = 取鼠标水平位置 ()
  18. y = 取鼠标垂直位置 ()
  19. 水平位置编辑框.内容 = 到文本 (x)
  20. 垂直位置编辑框.内容 = 到文本 (y)
  21.  
  22. .子程序 API鼠标位置
  23.  
  24. API_取鼠标位置 (a)
  25. x = a.水平位置
  26. y = a.垂直位置
  27. 水平位置编辑框.内容 = 到文本 (x)
  28. 垂直位置编辑框.内容 = 到文本 (y)
  29.  
  30. .子程序 取窗口内坐标
  31.  
  32. a.水平位置 = 取鼠标水平位置 ()
  33. a.垂直位置 = 取鼠标垂直位置 ()
  34. 到客户区坐标_ (取鼠标所在窗口句柄 (), a)
  35. x = a.水平位置
  36. y = a.垂直位置
  37. 水平位置编辑框.内容 = 到文本 (x)
  38. 垂直位置编辑框.内容 = 到文本 (y)


发布日期:

所属分类: 易语言 标签: