易语言调用API判断网络连接状态的三种源码

InternetCheckConnectionA

BOOL InternetCheckConnection(
  LPCTSTR lpszUrl, //是一个指向url字符串的指针,就是你要检测的链接,这个值是可以为空的。
  DWORD dwFlags,   //根据lpszUrl的值操作,空与非空有区别。
  DWORD dwReserved //是保留字,设置为0。
);

易语言

  1. .版本 2
  2.  
  3. .DLL命令 检查Internet连接_, 整数型, "wininet.dll", "InternetCheckConnectionA"
  4.     .参数 Url地址, 文本型, , lpszUrl
  5.     .参数 标志, 整数型, , dwFlags
  6.     .参数 返回值, 整数型, , dwReserved

调用

.版本 2
.支持库 spec
 
.子程序 _按钮_测试_被单击
 
.判断开始 (检查Internet连接_ (“http://www.baidu.com”, 1, 0) = 0)
    调试输出 (“连接到 http://www.baidu.com失败”)
.默认
    调试输出 (“连接到 http://www.baidu.com成功”

InternetAttemptConnect

.版本 2
 
.DLL命令 尝试Internet连接_, 整数型, "wininet.dll", "InternetAttemptConnect"
    .参数 返回值, 整数型, , dwReserved

调用判断

.版本 2
 
.子程序 _按钮_测试_被单击
 
.判断开始 (尝试Internet连接_ (0)0)
    编辑框_运行结果.内容 = “连接互联网成功”
.默认
    编辑框_运行结果.内容 = “连接互联网失败”
.判断结束

InetIsOffline

它只有一个参数,必须填0,MSDN指出,这个函数取得的结果不太准确。

  1. .版本 2
  2.  
  3. .DLL命令 是否连接因特网_, 整数型, "url.dll", "InetIsOffline"
  4.     .参数 标志值, 整数型, , dwFlags,默认值为0

调用测试

.版本 2
 
.子程序 _按钮_测试_被单击, , ,   
 
.判断开始 (是否连接因特网_ (0)0)
    编辑框_运行结果.内容 = “能连接到因特网”
.默认
    编辑框_运行结果.内容 = “不能连接到因特网”

发布日期:

所属分类: 易语言 标签: