易语言PathFindExtensionA获取文件扩展名

易语言API模块制作文件取扩展名

易语言函数原型

PTSTR PathFindExtension(
_In_ PTSTR pszPath//指向以0结尾,最大长度为MAX_PATH文件路径字符串指针。备注:一个有效的扩展名是不包括空格的。
);
返回值:
指向以0结尾,最大长度为MAX_PATH文件路径字符串指针。备注:一个有效的扩展名是不包括空格的。若找到后缀名,则返回一个指针,该指针是以点(.)为前缀的扩展名的地址;反之,返回null字符的地址。

.版本 2
 
.DLL命令 取文件扩展名_, 整数型, "shlwapi.dll", "PathFindExtensionA", , 无扩展名返回空
    .参数 文件路径, 文本型, , pszPath

调用

.版本 2
.支持库 spec
 
.子程序 _按钮_取文件扩展名_被单击
.局部变量 局部_路径文本, 文本型
.局部变量 局部_指针地址, 整数型
.局部变量 返回值, 文本型
 
局部_路径文本 = “C:\\Windows\\System32/notepad.exe”
局部_指针地址 = 取文件扩展名_ (局部_路径文本)
返回值 = 指针到文本 (局部_指针地址)
调试输出 (返回值)

参考:易语言取文件名和文件扩展名


发布日期:

所属分类: 易语言 标签: