易语言树型框取子项目索引源码

.版本 2
.支持库 iext

.子程序 取子项目索引, 整数型
.参数 搜寻对象, 文本型
.参数 树形框对象, 树型框
.参数 起始索引, 整数型
.局部变量 i, 整数型
.局部变量 初始层次, 整数型

初始层次 = 树形框对象.取缩进层次 (起始索引)
.如果真 (树形框对象.是否有子项目 (起始索引) = 假)
返回 (-1)
.如果真结束
.计次循环首 (树形框对象.取项目数 () - 起始索引, i)
.如果真 (树形框对象.取缩进层次 (起始索引 + i) ≤ 初始层次)
跳出循环 ()
.如果真结束
.如果真 (树形框对象.取项目文本 (起始索引 + i) = 搜寻对象)
返回 (起始索引 + i)
.如果真结束

.计次循环尾 ()
返回 (-1)


发布日期:

所属分类: 易语言 标签: