易语言PathStripToRootA删除根路径外文本

PathStripToRootA

.版本 2
 
.DLL命令 删除到根路径_, 逻辑型, "shlwapi.dll", "PathStripToRootA"
    .参数 路径文本, 文本型, , pszPath

易语言调用

例如:
原来路径文本:c:\abc\abd\abe.txt
返回:c:\

  1. .版本 2
  2.  
  3. .子程序 _按钮_删除到根路径_被单击
  4. .局部变量 局部_路径文本, 文本型
  5.  
  6. 局部_路径文本 = 编辑框_原路径文本.内容
  7. .判断开始 (删除到根路径_ (局部_路径文本) = 真)
  8.     编辑框_新路径文本.内容 = 局部_路径文本
  9. .默认
  10.     编辑框_新路径文本.内容 = “执行失败,可能路径文本格式错误”

发布日期:

所属分类: 易语言 标签: