易语言模块API视频教程窗口取所有子窗口句柄

取所有子窗口句柄 方法一源码

.版本 2

.子程序 窗口_取所有子句柄, 整数型, 公开, 取指定窗口的下一级子窗口的句柄,成功返回子窗口句柄的数目,失败返回0
.参数 父窗口句柄, 整数型, 可空, 指定窗口的句柄, 可空:为桌面,找顶级窗口下的所以子窗口
.参数 子窗口句柄数组, 整数型, 参考 数组, 返回所有符合条件的子窗口句柄(子窗口句柄数组)
.参数 窗口类名, 文本型, 可空, 窗口类名 零表示忽略
.局部变量 子句柄, 整数型
.局部变量 窗口标题, 文本型

清除数组 (子窗口句柄数组)
.循环判断首 ()
子句柄 = FindWindowExA (父窗口句柄, 子句柄, 窗口类名, 字符 (0))
.如果真 (子句柄 ≠ 0)
加入成员 (子窗口句柄数组, 子句柄)
.如果真结束

.循环判断尾 (子句柄 ≠ 0)
返回 (取数组成员数 (子窗口句柄数组))

取所有子窗口句柄 方法二源码

.版本 2

--------------------------------第二种写法-------------------
清除数组 (子窗口句柄数组)
子句柄 = FindWindowExA (父窗口句柄, 0, 窗口类名, 字符 (0))
.判断循环首 (子句柄 ≠ 0)
加入成员 (子窗口句柄数组, 子句柄)
子句柄 = FindWindowExA (父窗口句柄, 子句柄, 窗口类名, 字符 (0))
.判断循环尾 ()
返回 (取数组成员数 (子窗口句柄数组))


发布日期:

所属分类: 易语言 标签: