易语言PathSearchAndQualify格式化路径文本

寻找格式化路径PathSearchAndQualifyA

.版本 2
 
.DLL命令 寻找格式化路径_, 整数型, "shlwapi.dll", "PathSearchAndQualifyA"
    .参数 路径文本, 文本型, , pszPath
    .参数 缓冲区, 文本型, , pszBuf
    .参数 缓冲区大小, 整数型, , cchBuf

易语言调用

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 __启动窗口_创建完毕
 
' PathSearchAndQualifyA的作用是格式化一串路径文本。
' 例如:“c:/windows\system32\/\//user32.dll"返回
' "c:\windows\system32\user32.dll"
 
.子程序 _按钮_寻找格式化路径_被单击
.局部变量 局部_路径, 文本型
.局部变量 局部_缓冲区, 文本型
 
局部_路径 = 编辑框_文本.内容
局部_缓冲区 = 取空白文本 (260)
寻找格式化路径_ (局部_路径, 局部_缓冲区, 取文本长度 (局部_缓冲区))
编辑框_返回.内容 = 局部_缓冲区

发布日期:

所属分类: 易语言 标签: