易语言SHGetDiskFreeSpaceA取磁盘剩余空间

SHGetDiskFreeSpace 函数原型

BOOL SHGetDiskFreeSpace(
   LPCTSTR        pszVolume,
   ULARGE_INTEGER *pqwFreeCaller,
   ULARGE_INTEGER *pqwTot,
   ULARGE_INTEGER *pqwFree
);

易语言

  1. .版本 2
  2.  
  3. .DLL命令 取磁盘剩余空间_, 整数型, "shell32.dll", "SHGetDiskFreeSpaceA", , SHGetDiskFreeSpace
  4.     .参数 磁盘卷标, 文本型, , pszVolume
  5.     .参数 剩余空间1, 字节集, , pqwFreeCaller
  6.     .参数 总空间, 字节集, , pqwTot
  7.     .参数 剩余空间2, 字节集, , pqwFree

易语言调用

.版本 2
 
.程序集 窗口程序集_启动窗口
 
.子程序 _按钮_取硬盘空间_被单击
.局部变量 局部_可用剩余空间, 字节集
.局部变量 局部_总空间, 字节集
.局部变量 局部_剩余空间, 字节集
 
连续赋值 (取空白字节集 (8), 局部_可用剩余空间, 局部_总空间, 局部_剩余空间)
取磁盘剩余空间_ (“C:\”, 局部_可用剩余空间, 局部_总空间, 局部_剩余空间)
标签_运行结果.标题 = “可用剩余空间:” + 到文本 (取字节集数据 (局部_可用剩余空间, #长整数型, )) + #换行符 + “总空间:” + 到文本 (取字节集数据 (局部_总空间, #长整数型, )) + #换行符 + “剩余空间:” + 到文本 (取字节集数据 (局部_剩余空间, #长整数型, ))

发布日期:

所属分类: 易语言 标签: