易语言乐玩插件FindMultiColor找色多点及找色块

乐玩插件模块源码:

.版本 2

.子程序 FindMultiColor, 整数型, 公开, 0:失败,1:成功
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 first_color, 文本型
.参数 offset_color, 文本型
.参数 sim, 小数型
.参数 dir
返回 (obj.数值方法 (“FindMultiColor”, x1, y1, x2, y2, first_color, offset_color, sim, dir))

.子程序 FindColorBlock, 整数型, 公开, 返回指定颜色出现的最多次数
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 w
.参数 h
.参数 color, 文本型
.参数 sim, 小数型
.参数 countModel
.参数 colorCount
.参数 pointModel
返回 (obj.数值方法 (“FindColorBlock”, x1, y1, x2, y2, w, h, color, sim, countModel, colorCount, pointModel))

.子程序 FindColorBlock2, 整数型, 公开, 找到返回1,否则返回0
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 w
.参数 h
.参数 color, 文本型
.参数 sim, 小数型
.参数 dir
返回 (obj.数值方法 (“FindColorBlock2”, x1, y1, x2, y2, w, h, color, sim, dir))

乐玩多点找色及找色块调用源码:

.版本 2
.支持库 spec
 
.子程序 _按钮8_被单击, , , FindMultiColor
 
l.FindMultiColor (737, 136, 789, 197, “ffeedd-000000”,1|2|ffeedd-000000”, 1, 2)
l.MoveTo (l.GetX (), l.GetY ())
l.LeftDoubleClick ()
 
.子程序 _按钮9_被单击, , , FindColorBlock
 
l.FindColorBlock (737, 136, 789, 197, 10, 20, “ffeedd-000000”, 1, 0, 0, 0)
l.MoveTo (l.GetX (), l.GetY ())
l.LeftDoubleClick ()
 
.子程序 _按钮10_被单击, , , FindColorBlock-2
.局部变量 ret
 
ret = l.FindColorBlock2 (761, 138, 793, 168, 10, 5, “ffeedd-000000,10,20, 1, 2)
调试输出 (ret)
l.MoveTo (l.GetX (), l.GetY ())
调试输出 (l.GetX ())
调试输出 (l.GetY ())
l.LeftDoubleClick ()

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: