易语言教程选择框一键选中与取消

易语言选择框属性源码:

.版本 2

.子程序 _选择框1_被单击

.如果真 (选择框1.选中 = 真)
选择框2.选中 = 假
选择框3.选中 = 假
编辑框1.内容 = “”
编辑框1.加入文本 (“你选择了 A”)
.如果真结束

.子程序 _选择框2_被单击

.如果真 (选择框2.选中 = 真)
选择框2.文本颜色 = #红色
选择框1.选中 = 假
选择框3.选中 = 假
编辑框1.内容 = “”
编辑框1.加入文本 (“你选择了 B”)
.如果真结束

.子程序 _选择框3_被单击

.如果真 (选择框3.选中 = 真)
选择框3.文本颜色 = #红色
选择框1.选中 = 假
选择框2.选中 = 假
编辑框1.内容 = “”
编辑框1.加入文本 (“你选择了 C”)

易语言选择框一键全部选中和取消源码:

.版本 2

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 组件句柄, 整数型
.局部变量 组件数量, 整数型
.局部变量 n, 整数型
.局部变量 自定义选择框, 选择框

组件句柄 = 寻找组件 (_启动窗口, “选择框”, , , )
组件数量 = 取找到组件数目 (组件句柄)
.计次循环首 (组件数量, n)
组件数量 = 组件数量 - 1
自定义选择框 = 取所找到组件 (组件句柄, 组件数量)
自定义选择框.选中 = 真
.计次循环尾 ()
清除组件寻找句柄 (组件句柄)

.子程序 _按钮2_被单击
.局部变量 组件句柄, 整数型
.局部变量 组件数量, 整数型
.局部变量 n, 整数型
.局部变量 自定义选择框, 选择框

组件句柄 = 寻找组件 (_启动窗口, “选择框”, , , )
组件数量 = 取找到组件数目 (组件句柄)
.计次循环首 (组件数量, n)
组件数量 = 组件数量 - 1
自定义选择框 = 取所找到组件 (组件句柄, 组件数量)
自定义选择框.选中 = 假
.计次循环尾 ()
清除组件寻找句柄 (组件句柄)

教程下载:

1-40
百度网盘链接:https://pan.baidu.com/s/1qbtE2cgi9sU1vganeIuv7w
41-88
百度网盘链接:https://pan.baidu.com/s/1Yf0neUBcUtet_eNN0SzNnQ

提取码:加QQ群:521068947 群文件下载

511遇见全部视频教程百度网盘下载

资源教程交流①群:521068947

511遇见QQ: 272586593


发布日期:

所属分类: 易语言 标签: