易语言大漠单线程模块制作设置字库及OcrEx识别字符串

大漠接口说明OcrEx

函数简介:
 
识别屏幕范围(x1,y1,x2,y2)内符合color_format的字符串,并且相似度为sim,sim取值范围(0.1-1.0),
 
这个值越大越精确,越大速度越快,越小速度越慢,请斟酌使用!
 
这个函数可以返回识别到的字符串,以及每个字符的坐标.
 
函数原型:
 
string OcrEx(x1,y1,x2,y2,color_format,sim)
 
参数定义:
 
x1 整形数:区域的左上X坐标
y1 整形数:区域的左上Y坐标
x2 整形数:区域的右下X坐标
y2 整形数:区域的右下Y坐标
color_format 字符串:颜色格式串.注意,RGB和HSV格式都支持.
sim 双精度浮点数:相似度,取值范围0.1-1.0
 
返回值:
 
字符串:
返回识别到的字符串 格式如  "字符0$x0$y0|…|字符n$xn$yn"
 
示例:
 
和Ocr函数相同,只是结果处理有所不同 如下
 
dm_ret = dm.OcrEx(0,0,2000,2000,"ffffff|000000",1.0)
ss = split(dm_ret,"|")
index = 0
count = UBound(ss) + 1
Do While index < count
   TracePrint ss(index)
   sss = split(ss(index),"$")
   ocr_s = int(sss(0))
   x = int(sss(1))
   y = int(sss(2))
   TracePrint ocr_s & ","&x&","&y
   index = index+1
Loop
 
注: OcrEx不再像Ocr一样,支持换行分割了.

视频教程源码

.版本 2

.子程序 OcrEx, 文本型, 公开, 识别屏幕范围(x1,y1,x2,y2)内符合color_format的字符串,并且相似度为sim,sim取值范围(0.1-1.0),返回值(返回识别到的字符串 格式如 "字符0$x0$y0|…|字符n$xn$yn")OcrEx不再像Ocr一样,支持换行分割了.
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color_format, 文本型, , color_format 字符串:颜色格式串. 可以包含换行分隔符,语法是","后加分割字符串. 具体可以查看下面的示例.注意,RGB和HSV格式都支持
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0

返回 (obj.文本方法 (“OcrEx”, x1, y1, x2, y2, color_format, sim))

.子程序 OcrExOne, 文本型, 公开, 识别屏幕范围(x1,y1,x2,y2)内符合color_format的字符串,并且相似度为sim,sim取值范围(0.1-1.0),返回值(返回识别到的字符串 格式如 "字符0$x0$y0|…|字符n$xn$yn")OcrEx不再像Ocr一样,支持换行分割了).
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color_format, 文本型, , color_format 字符串:颜色格式串. 可以包含换行分隔符,语法是","后加分割字符串. 具体可以查看下面的示例.注意,RGB和HSV格式都支持
.参数 sim, 双精度小数型, , sim 双精度浮点数:相似度,取值范围0.1-1.0

返回 (obj.文本方法 (“OcrExOne”, x1, y1, x2, y2, color_format, sim))

.子程序 UseDict, 整数型, 公开, 表示使用哪个字库文件进行识别(index范围:0-9)设置之后,永久生效,除非再次设定(返回值:0失败,1成功)
.参数 index, 整数型, , index 整形数:字库编号(0-9)

返回 (obj.数值方法 (“UseDict”, index))

.子程序 AddDict, 整数型, 公开, 给指定的字库中添加一条字库信息.
.参数 index, 整数型, , index 整形数:字库的序号,取值为0-19,目前最多支持20个字库
.参数 dict_info, 文本型, , dict_info 字符串:字库描述串,具体参考大漠综合工具中的字符定义

返回 (obj.数值方法 (“AddDict”, index, dict_info))

.子程序 ClearDict, 整数型, 公开, 清空指定的字库.此函数支持清空内存中的字库,而不是字库文件本身
.参数 index, 整数型, , index 整形数:字库的序号,取值为0-19,目前最多支持20个字库

返回 (obj.数值方法 (“ClearDict”, index))

.子程序 FetchWord, , 公开, 根据指定的范围,以及指定的颜色描述,提取点阵信息,类似于大漠工具里的单独提取.识别到的点阵信息,可用于AddDict(失败返回为空)
.参数 x1, 整数型, , x1 整形数:区域的左上X坐标
.参数 y1, 整数型, , y1 整形数:区域的左上Y坐标
.参数 x2, 整数型, , x2 整形数:区域的右下X坐标
.参数 y2, 整数型, , y2 整形数:区域的右下Y坐标
.参数 color, 文本型, , color 字符串: 颜色格式串.注意,RGB和HSV格式都支持.
.参数 word, 文本型, , word 字符串: 待定义的文字,不能为空,且不能为关键符号"$"

返回 (obj.文本方法 (“FetchWord”, x1, y1, x2, y2, color, word))

视频教程优酷土豆链接:


发布日期:

所属分类: 易语言 标签: