易语言内存注入注入模块测试调用

511遇见

内存注入模块调用源码:

.版本 2
.支持库 spec
 
.程序集 窗口程序集_启动窗口
.程序集变量 窗口句柄
.程序集变量 进程句柄
.程序集变量 a, 内存DLL注入
.程序集变量 hadress
 
.子程序 __启动窗口_创建完毕
 
.子程序 _按钮1_被单击
.局部变量 PID, 整数型
 
窗口句柄 = 到整数 (编辑框1.内容)
GetWindowThreadProcessId (窗口句柄, PID)
进程句柄 = OpenProcess (2035711,, PID)
a.注入DLL (进程句柄, #图片1)
.子程序 _按钮2_被单击
 
hadress = a.执行DLL函数 (“Start”, , , , 窗口句柄, , , , , , , , , )
调试输出 (hadress)

注入DLL源码

.版本 2
 
.程序集 程序集1
 
.子程序 _启动子程序, 整数型, , 请在本子程序中放置动态链接库初始化代码
 
_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 返回值被忽略。
 
.子程序 _临时子程序
 
' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
 
.子程序 Start, , 公开
 
载入 (窗口1, , 真)

教程获取下载:


发布日期:

所属分类: 易语言 标签: