511遇见易语言多线程大漠多线程-11多线程多参数自定义封装

多线程多参数自定义封装

• 1、启动线程_自定义(,,,,,,)
• 2、.版本 2
• 文件号 = 打开内存文件 ()
• 写出数据 (文件号, 参数1, 参数2, 参数3, 参数4)
• 启动线程 (子程序指针, 文件号, 线程句柄)
• 3、移到文件首 (文件号)
• 读入数据 (文件号, 整数, 字节集1, 逻辑, 文本)
• 关闭文件 (文件号)
教程源码:

.子程序 启动线程_自定义, 整数型, 公开, 局线程句柄
.参数 子程序指针, 子程序指针
.参数 参数1, 整数型
.参数 参数2, 字节集
.参数 参数3, 文本型, , 只需要封装一个多参的文本型的就可以了
.参数 参数4, 逻辑型
.参数 文件号, 整数型, 参考 可空, 如果要强制结束线程,先关闭文件()
.局部变量 局线程句柄, 整数型
.局部变量 文件号, 整数型

文件号 = 打开内存文件 ()
写出数据 (文件号, 参数1, 参数2, 参数3, 参数4)
启动线程 (子程序指针, 文件号, 局线程句柄)
返回 (局线程句柄)

.子程序 子程序1
.参数 文件号, 整数型
.局部变量 整数, 整数型
.局部变量 字节集, 字节集
.局部变量 文本, 文本型
.局部变量 逻辑, 逻辑型

移到文件首 (文件号)
读入数据 (文件号, 整数, 字节集, 文本, 逻辑)
关闭文件 (文件号)
信息框 (到文本 (整数) + 到文本 (字节集) + 文本 + 到文本 (逻辑), 0, , )

.子程序 __启动窗口_将被销毁

关闭线程句柄 (T_hwnd)


发布日期:

所属分类: 易语言 标签: