易语言大漠《剑侠情缘》多线程批量登录账号加入超级列表框

部分源码

.版本 2
.支持库 iext
 
.子程序 账号加入列表框, , , 把选中的账号加入到列表框里
.局部变量 i, 整数型
.局部变量 m, 整数型
 
超级列表框1.全部删除 ()
' 去除数组重复的成员
.计次循环首 (取数组成员数 (account), i)
    .如果真 (i > 取数组成员数 (account))
        跳出循环 ()
    .如果真结束
    .计次循环首 (取数组成员数 (account) - i, )
        m = m + 1
        .如果真 (account [i] = account [i + m])
            删除成员 (account, i + m, )
            m = m - 1
 
        .如果真结束
        .如果真 (i + m = 取数组成员数 (account))
            m = 0
            跳出循环 ()
 
        .如果真结束
 
    .计次循环尾 ()
.计次循环尾 ()
' 把账号加入超级列表框
.计次循环首 (取数组成员数 (account), i)
    超级列表框1.插入表项 (1, account [i], , , , )


发布日期:

所属分类: 易语言 标签: