511遇见易语言多线程大漠多线程-5线程传参内存地址

L5-线程传参-指针地址

• 1、到字节集(文本变量)
• 2、取字节集长度()
• 3、申请内存()
• 4、写到内存()
• 4、线程启动(&子程序1,内存指针,)
课程源码:
.子程序 _按钮1_被单击
.局部变量 手机号码, 字节集
.局部变量 内存指针, 整数型

置随机数种子 ()
手机号码 = 到字节集 (“1390359” + 到文本 (取随机数 (1111, 9999)))
长度 = 取字节集长度 (手机号码)
内存指针 = 申请内存 (长度, 假)
写到内存 (手机号码, 内存指针, 长度)
启动线程 (&子程序1, 内存指针, )

.子程序 子程序1
.参数 参数, 整数型
.局部变量 手机, 字节集
.局部变量 str, 文本型

手机 = 指针到字节集 (参数, 长度)
str = 到文本 (手机)
编辑框1.加入文本 (str + #换行符)

.子程序 _按钮1_被单击
.局部变量 手机号码, 字节集
.局部变量 内存指针, 整数型
.局部变量 n, 整数型

置随机数种子 ()
.计次循环首 (20, n)
手机号码 = 到字节集 (“1390359” + 到文本 (取随机数 (1111, 9999)))
长度 = 取字节集长度 (手机号码)
内存指针 = 申请内存 (长度, 假)
写到内存 (手机号码, 内存指针, 长度)
启动线程 (&子程序1, 内存指针, )

.计次循环尾 ()

.子程序 子程序1
.参数 参数, 整数型
.局部变量 手机, 字节集
.局部变量 str, 文本型

手机 = 指针到字节集 (参数, 长度)
str = 到文本 (手机)
编辑框1.加入文本 (str + #换行符)


发布日期:

所属分类: 易语言 标签: