第13课易语言大漠一键登录账号写入组合框列表

源码:

.版本 2
 
.子程序 账号密码写入组合框
.局部变量 word, 文本型
.局部变量 w_array, 文本型, , "0"
.局部变量 n, 整数型
.局部变量 array, 文本型, , "0"
.局部变量 name, 文本型
.局部变量 password, 文本型
.局部变量 m, 整数型
 
组合框1.清空 ()
word = 到文本 (读入文件 (取运行目录 () + “\zhm.txt”))
w_array = 分割文本 (word, #换行符, )
.计次循环首 (取数组成员数 (w_array), n)
    array = 分割文本 (w_array [n],|, )
    name = array [1]
    password = array [2]
    .计次循环首 (组合框1.取项目数 (), m)
        .如果真 (w_array [n] = 组合框1.取项目文本 (m - 1))
            跳出循环 ()
        .如果真结束
 
    .计次循环尾 ()
    .如果真 (m > 组合框1.取项目数 ())
        组合框1.加入项目 (name, )
 
    .如果真结束
 
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: