511遇见易语言多线程大漠多线程-10线程传参-时钟多线程数组传参

传参-时钟多线程-数组传参

1、时钟组件
2、数组传参
3、多线程传参
教程源码:

.版本 2
.支持库 EThread
.支持库 spec
 
.局部变量 n, 整数型
 
n = 取数组成员数 (A_str)
重定义数组 (A_str,, n + 1)
置随机数种子 ()
A_str [n + 1] = “511遇见” + “|” + “www.511yj.com” + “|” + “不一样的遇见” + 时间到文本 (取现行时间 (), ) + “|” + 到文本 (取随机数 (666, 999))
启动线程 (&子程序1, 取变量数据地址 (A_str [n + 1]), T_hwnd)
' 时钟是按照顺序,不需要加等待线程
 
.子程序 子程序1
.参数 参_a, 文本型
.局部变量 文本, 文本型, , "0"
.局部变量 n, 整数型
 
文本 = 分割文本 (参_a, “|”, )
.计次循环首 (取数组成员数 (文本), n)
    编辑框1.加入文本 (文本 [n] + #换行符)
.计次循环尾 ()
关闭线程句柄 (T_hwnd)
 
 
.子程序 _按钮_启动线程_被单击, , , 启动线程
 
.判断开始 (编辑框2.内容 ≠ “”)
    时钟1.时钟周期 = 到整数 (编辑框2.内容)
.默认
    信息框 (“请输入时钟周期”, 0, , )
.判断结束
 
 
.子程序 _按钮_停止线程_被单击, , , 停止线程
 
时钟1.时钟周期 = 0


发布日期:

所属分类: 易语言 标签: