易语言注册调用乐玩插件类模块封装

教程源码:

.版本 2
 
.程序集 lwcom, , 公开
.程序集变量 obj, 对象
 
.子程序 _初始化, , , 当基于本类的对象被创建后,此方法会被自动调用
.局部变量 DLL路径, 文本型
 
DLL路径 = 取运行目录 () + “\Obj\lw.dll”
创建目录 (取运行目录 () + “\Obj”)
 
写到文件 (DLL路径, #lwdll)
置文件属性 (DLL路径, 12432)
 
运行 (“regsvr32  ” + DLL路径 + “ /s”,, 1)
 
obj.创建 (“lw.lwsoft3, )
 
.子程序 _销毁, , , 当基于本类的对象被销毁前,此方法会被自动调用
 
.子程序 ver, 文本型, 公开
 
返回 (obj.文本方法 (“ver”, ))

调用测试:

.版本 2
 
.程序集 窗口程序集_启动窗口
.程序集变量 l, lwcom
 
.子程序 __启动窗口_创建完毕
.子程序 _按钮1_被单击
 
信息框 (l.ver (), 0, , )

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: