易语言自动判断文本文件编码和转换

最简单的直接调用精易模块里的
文件_取文本编码()
返回值:
获取指定路径的txt文档的编码格式。成功返回(1:UTF-8,2:Unicode;3:Unicode big endian;4:ANSI),默认返回 4。注:请确保文件能被正常读入。

读入文本
byte = 读入文件 (取运行目录 () + “\temp\path.txt”)
判断转换

.版本 2
.支持库 spec
 
.局部变量 byte, 字节集
 
byte = 读入文件 (取运行目录 () + “\temp\path.txt)
 
.判断开始 (取字节集左边 (byte, 2){ 255, 254 })  ' Unicode
    调试输出 (“编码:Unicode”, 编码_Unicode到Ansi_对象 (byte))
.判断 (取字节集左边 (byte, 2) = { 254, 255 })  ' Unicode big endian
    调试输出 (“编码:Unicode”, 编码_Unicode到Ansi_对象 (byte))
.判断 (取字节集左边 (byte, 3){ 239, 187, 191 })  ' UTF-8
    调试输出 (“编码:UTF-8”, 编码_Utf8到Ansi_对象 (byte))
.默认
    调试输出 (“编码:ANSI”, 到文本 (byte))  ' ANSI
.判断结束

发布日期:

所属分类: 编程, 编程语言 标签: