易语言应用接口支持库提取exe、dll、ico资源文件图标

提取资源文件图标

提取资源文件图标 命令 操作系统支持:Windows 所属类别:系统处理

从指定的资源文件中提取图标,并保存为ICO、BMP文件或复制到剪贴板。成功返回图标数量;失败返回0。

参数名 描述
资源文件 名必需的;文本型。要提取图标的资源文件名。扩展名为EXE、DLL、ICL、ICO。
提取到 可选的; 整数型。要提取图标到何处,可以为以下常量值之一:0、#接口常量.到文件; 1、#接口常量.到剪贴板。
保存文件名 可选的;文本型。提取的图标要保存的文件名。扩展名为ICO、BMP。
图标序号 可选的;整数型。当资源文件中包含多个图标时,表示要提取图标的序号。

教程源码截图

从指定的资源文件中提取图标,并保存为ICO、BMP文件或复制到剪贴板。

511遇见

教程源码

.版本 2
.支持库 eAPI
 
.子程序 _提取资源文件图标按钮_被单击
.局部变量 文件名, 文本型
 
通用对话框1.过滤器 = “资源文件|*.exe;*.dll;*.ico;*.icl”
.如果真 (通用对话框1.打开 ())
    文件名 = 取文件名 (通用对话框1.文件名)
    文件名 = 去文件名后缀 (文件名)
    提取资源文件图标 (通用对话框1.文件名, 0, 取运行目录 () + “\” + 文件名 + “.ico”, )
    信息框 (“文件已保存为” + 取运行目录 () + “\” + 文件名 + “.ico”, 0, )
.如果真结束

发布日期:

所属分类: 易语言 标签: