易语言MySql支持库连接MySql

连接MySql

连接MySql 命令 操作系统支持:Windows 所属类别:MySql支持库

连接到MySql服务器,返回一个MySql句柄。

语法: 整数型 连接MySql (MySql服务器地址,用户名,密码,数据库名,端口)

参数名 描 述
MySql服务器地址 必需的;文本型。您想要连接的MySql服务器的地址,如果为空字符串("")或字符串"localhost",是到本地主机的一个连接。
用户名 必需的;文本型。您的用户名,如果为空字符串(""),为当前用户。
密码 必需的;文本型。您的密码,如果为空字符串(""),USER表中存在空字段是可用。
数据库名 必需的;文本型。您想要连接的服务器,如果为空字符串("")默认数据库。
端口 必需的;整数型。您想要连接的MySql服务器的端口,如果为0则为默认端口。

连接MySql截图

511遇见

511遇见

连接MySql源码

连接MySql服务器,如果都为空则连接本地主机。

.版本 2
.支持库 mysql
.支持库 spec
 
Mysql句柄 = 连接MySql (“127.0.0.1”, “root”, “root123”, “test”, 3306)
查询部门语句 = “select * from department”
执行SQL语句 (Mysql句柄, 查询部门语句)
记录集句柄 = 取记录集 (Mysql句柄)
记录数 = 取记录集行数 (记录集句柄)
调试输出 (“记录数:” + 到文本 (记录数))
.如果 (记录集句柄 ≠ 0)
    调试输出 (“连接数据库成功!”)
    按钮_连接数据库.禁止 = 真
    ' 取字段填充到列表
    .计次循环首 (取字段总数 (记录集句柄), n)
        序号到字段名 (记录集句柄, n - 1, 字段名)
        列表框1.加入项目 (字段名, )
    .计次循环尾 ()
.否则
    信息框 (“连接数据库失败!”, 0, , )
.版本 2
.支持库 mysql
 
.程序集 启动窗口程序集
.程序集变量 MySql句柄, 整数型
.程序集变量 记录集句柄, 整数型
 
.子程序 __启动窗口_创建完毕
.局部变量 服务器版本, 文本型
.局部变量 客户端版本, 文本型
 
MySql句柄 = 连接MySql (“”, “root”, “”, “test”, 0)
' 连接本地MySql数据库
执行SQL语句 (MySql句柄, “select * from test”)
记录集句柄 = 取记录集 (MySql句柄)
取服务器版本 (MySql句柄, 服务器版本)
取客户端版本 (客户端版本)
信息列表框.加入项目 (“MySql句柄:” + 到文本 (MySql句柄), )
信息列表框.加入项目 (“服务器版本:” + 服务器版本, )
信息列表框.加入项目 (“客户端版本:” + 客户端版本, )
信息列表框.现行选中项 = 信息列表框.取项目数 () - 1

发布日期:

所属分类: 易语言 标签: