易语言应用接口支持库MySql支持库增加记录

增加记录

增加记录 命令 操作系统支持:Windows 所属类别:MySql支持库

写入信息到新记录的指定字段,执行成功返回真,失败返回假。

语法: 逻辑型 增加记录 (MySql句柄,表名,赋值语句)

参数名 描述
MySql句柄 必需的;整数型。调用 连接MySql 的返回值。
表名 必需的;文本型。您要写入新记录的表的名称。
赋值语句 必需的;文本型。您要执行的赋值语句.例子 增加一条记录并且为字段name与email赋予值jack与jack@126.com name='jack',email='jack@126.com'。

例程截图

在记录集的尾部增加一条新记录,字节集类型记录不能使用该命令增加。

511遇见

例程源码:

.版本 2
.支持库 mysql
.支持库 iext
 
.子程序 _增加记录按钮_被单击
.局部变量 name字段, 文本型
.局部变量 索引, 整数型
.局部变量 number字段, 文本型
.局部变量 赋值语句, 文本型
 
输入框 (“赋值语句”, , “name='易语言',number=123”, 赋值语句, )
.如果真 (增加记录 (MySql句柄, “test”, 赋值语句) = 真)
    数据库超级列表框.全部删除 ()
    释放记录集 (记录集句柄)
    执行SQL语句 (MySql句柄, “select * from test”)
    记录集句柄 = 取记录集 (MySql句柄)
    到首行 (记录集句柄)
    .计次循环首 (取记录集行数 (记录集句柄), )
        读字段值 (记录集句柄, “name”, name字段)
        索引 = 数据库超级列表框.插入表项 (, name字段, , , , )
        读字段值 (记录集句柄, “number”, number字段)
        数据库超级列表框.置标题 (索引, 1, number字段)
        到下一行 (记录集句柄)
    .计次循环尾 ()
    信息列表框.加入项目 (“增加记录执行完毕!”, )
    信息列表框.现行选中项 = 信息列表框.取项目数 () - 1

发布日期:

所属分类: 易语言 标签: