易语言应用接口支持库系统处理取硬盘信息

取硬盘信息

取硬盘信息 命令 操作系统支持:Windows 所属类别:系统处理

取硬件出厂信息。

语法: 逻辑型 取硬盘信息 (硬盘信息,[硬盘序号])

参数名 描 述

硬盘信息 必需的;硬盘信息。待取得的硬盘信息。

硬盘序号 可选的;整数型。待取得的硬盘信息的硬盘序号。可以为以下常量之一:0、#接口常量.磁盘0;1、#接口常量.磁盘1;2、#接口常量.磁盘2;3、#接口常量.磁盘3。

例程截图

取出硬盘的所有信息,最多可以取出四块硬盘的所有信息。

511遇见

例程源码:

.版本 2
.支持库 eAPI

.程序集 _启动窗口程序集

.子程序 _取硬盘信息按钮_被单击
.局部变量 硬盘信息, 硬盘信息

.如果真 (取硬盘信息 (硬盘信息, ))
信息框 (“硬盘信息.型号 :” + 硬盘信息.型号 + 字符 (10) + 字符 (13) + “硬盘信息.版本号 :” + 硬盘信息.版本号 + 字符 (10) + 字符 (13) + “硬盘信息.序列号 ” + 到文本 (硬盘信息.序列号) + 字符 (10) + 字符 (13) + “硬盘信息.容量 :” + 到文本 (硬盘信息.容量) + “(M)” + 字符 (10) + 字符 (13) + “硬盘信息.缓存大小 :” + 到文本 (硬盘信息.缓存大小) + “(M)” + 字符 (10) + 字符 (13) + “硬盘信息.每磁道扇区数 :” + 到文本 (硬盘信息.每磁道扇区数) + 字符 (10) + 字符 (13) + “硬盘信息.磁头数 :” + 到文本 (硬盘信息.磁头数) + 字符 (10) + 字符 (13) + “硬盘信息.柱面数 :” + 到文本 (硬盘信息.柱面数), 0, )
.如果真结束

.子程序 _取驱动器数量按钮_被单击

信息框 (“驱动器共” + 到文本 (取驱动器数量 (0)) + “个”, 0, )
信息框 (“硬盘驱动器共” + 到文本 (取驱动器数量 (1)) + “个”, 0, )
信息框 (“光盘驱动器共” + 到文本 (取驱动器数量 (2)) + “个”, 0, )
信息框 (“可移动驱动器共” + 到文本 (取驱动器数量 (3)) + “个”, 0, )
信息框 (“网络驱动器共” + 到文本 (取驱动器数量 (4)) + “个”, 0, )

.子程序 _取驱动器列表按钮_被单击
.局部变量 驱动器数量, 整数型
.局部变量 驱动器列表, 文本型, , "0"
.局部变量 记次循环变量, 整数型

列表框1.清空 ()
驱动器列表 = 取驱动器列表 (1)
驱动器数量 = 取数组成员数 (驱动器列表)
.计次循环首 (驱动器数量, 记次循环变量)
列表框1.加入项目 (驱动器列表 [记次循环变量] + “ 硬盘驱动器”, )
.计次循环尾 ()
驱动器列表 = 取驱动器列表 (2)
驱动器数量 = 取数组成员数 (驱动器列表)
.计次循环首 (驱动器数量, 记次循环变量)
列表框1.加入项目 (驱动器列表 [记次循环变量] + “ 光盘驱动器”, )
.计次循环尾 ()
驱动器列表 = 取驱动器列表 (3)
驱动器数量 = 取数组成员数 (驱动器列表)
.计次循环首 (驱动器数量, 记次循环变量)
列表框1.加入项目 (驱动器列表 [记次循环变量] + “ 可移动驱动器”, )
.计次循环尾 ()
驱动器列表 = 取驱动器列表 (4)
驱动器数量 = 取数组成员数 (驱动器列表)
.计次循环首 (驱动器数量, 记次循环变量)
列表框1.加入项目 (驱动器列表 [记次循环变量] + “ 网络驱动器”, )
.计次循环尾 ()

.子程序 _弹出光驱按钮_被单击

弹出光驱 ()

.子程序 _关闭光驱按钮_被单击

关闭光驱 ()

.子程序 _取光驱盘符按钮_被单击

信息框 (取光驱盘符 (), 0, )

.子程序 _光驱中是否有盘按钮_被单击

信息框 (光驱中是否有盘 (), 0, )


发布日期:

所属分类: 易语言 标签: