易语言应用接口支持库系统处理取内存容量信息

易语言GlobalMemoryStatus获取物理和虚拟内存信息

取内存容量信息

取内存容量信息 命令 操作系统支持:Windows 所属类别:系统处理

取内存容量信息,单位为M(兆)。

语法: 整数型 取内存容量信息 ([内存类型])

参数名 描 述

内存类型 可选的;整数型。要取得的内存类型,可以为以下常量值之一:0、#接口常量.总物理内存;1、#接口常量.可用物理内存;2、#接口常量.总虚拟内存;3、#接口常量.可用虚拟内存;4、#接口常量.总页面文件;5、#接口常量.可用页面文件。

例程截图:

取内存容量信息。要取得的内存类型,可以为以下常量值之一:0、#接口常量.总物理内存;1、#接口常量.可用物理内存;2、#接口常量.总虚拟内存;3、#接口常量.可用虚拟内存;4、#接口常量.总页面文件;5、#接口常量.可用页面文件。

511遇见

取内存容量信息源码:

.版本 2
.支持库 EChartBar
.支持库 eAPI
.子程序 _取CPU占用率按钮_被单击
 
.如果 (逻辑标识 = 真)
    时钟1.时钟周期 = 1000
    逻辑标识 = 假
.否则
    时钟1.时钟周期 = 0
    逻辑标识 = 真
    CPU占用图.当前数据值 = 0
.如果结束
 
.子程序 _时钟1_周期事件
.局部变量 CPU占用率, 整数型
 
CPU占用率 = 取CPU占用率 ()
' CPU占用图.当前X轴标注文字 = 到文本 (CPU占用率)
CPU占用图.当前数据值 = CPU占用率
 
.子程序 _取内存容量信息按钮_被单击
.局部变量 总虚拟内存, 整数型
.局部变量 可用虚拟内存, 整数型
.局部变量 总页面文件, 整数型
.局部变量 可用页面文件, 整数型
 
' 内存类型  0、总物理内存;1、可用物理内存;2、总虚拟内存;3、可用虚拟内存;4、总页面文件;5、可用页面文件。
时钟2.时钟周期 = 1000
 
.子程序 _时钟2_周期事件
.局部变量 总物理内存, 整数型
.局部变量 可用物理内存, 整数型
 
总物理内存 = 取内存容量信息 (0)
可用物理内存 = 取内存容量信息 (1)
内存使用情况图.当前图例索引 = 0
内存使用情况图.当前数据值 = 总物理内存 - 可用物理内存
内存使用情况图.当前图例索引 = 1
内存使用情况图.当前数据值 = 可用物理内存

发布日期:

所属分类: 易语言 标签: