易语言RtlFillMemory填充内存与内存清零

RtlFillMemory

.版本 2
 
.DLL命令 RtlFillMemory, 整数型, "kernel32.dll", "RtlFillMemory", , 用指定的值添充指定长度的内存块
    .参数 Destination, 文本型, , 目标地址指针
    .参数 Length, 整数型, , 目标大小
    .参数 Fill, 字节型, , 指定的值

RtlZeroMemory

.版本 2
 
.DLL命令 RtlZeroMemory, 整数型, "kernel32.dll", "RtlZeroMemory", , 该函数将指定的一段内存区域添零.如果函数成功,返回非零。否则还回零。
    .参数 lpDestination, 文本型, , 指定内存区域开始的地址指针
    .参数 Length, 整数型, , 指定内存区域的大小或长度

易语言调用

.版本 2
 
.程序集 窗口程序集_启动窗口
.程序集变量 程序集_文本, 文本型
 
.子程序 __启动窗口_创建完毕
 
.子程序 _按钮_填充内存_被单击
 
编辑框_运行结果.内容 = “”
程序集_文本 = 取重复文本 (25, “X”)
编辑框_运行结果.内容 = “这是我们的启始内存: ” + 程序集_文本
RtlFillMemory (程序集_文本, 取文本长度 (程序集_文本), 取代码 (“A”, ))
编辑框_运行结果.内容 = 编辑框_运行结果.内容 + #换行符 + #换行符 + “这是填充内存: ” + 程序集_文本

.子程序 _按钮_内存清零_被单击
 
编辑框_运行结果.内容 = “”
RtlZeroMemory (程序集_文本, 取文本长度 (程序集_文本))
编辑框_运行结果.内容 = “这是内存清零: ” + 程序集_文本

发布日期:

所属分类: 易语言 标签: