易语言原子自动递增与递减

InterlockedDecrement

  1. .版本 2
  2.  
  3. .DLL命令 InterlockedDecrement, 整数型, "kernel32.dll", "InterlockedDecrement", , 变量的上一个值
  4.     .参数 递减的一个变量, 整数型, 传址, InterlockedIncrement

易语言调用

  1. .版本 2
  2.  
  3. .局部变量 要减少的变量
  4.  
  5. 要减少的变量 = 0
  6. .计次循环首 (100, )
  7.     输出调试文本 (InterlockedDecrement (要减少的变量))
  8. .计次循环尾 ()

开始运行被调试程序
* -1
* -2
* -3
* -4
* -5
* -6
* -7
* -8
* -9
* -10
* -11
* -12
* -13
* -14
* -15

InterlockedIncrement

  1. .版本 2
  2.  
  3. .DLL命令 InterlockedIncrement, 整数型, "kernel32.dll", "InterlockedIncrement"
  4.     .参数 Addend, 整数型, 传址

xxx

  1. .版本 2
  2.  
  3. .子程序 _按钮1_被单击
  4. .局部变量 要减少的变量
  5.  
  6. 要减少的变量 = 0
  7. .计次循环首 (100, )
  8.     输出调试文本 (InterlockedIncrement (要减少的变量))
  9. .计次循环尾 ()

开始运行被调试程序
* 1
* 2
* 3
* 4
* 5
* 6
* 7
* 8
* 9
* 10


发布日期:

所属分类: 易语言 标签: