易语言模块API视频教程窗口取标题(GetWindowTextA)

API GetWindowTextA

GetWindowTextA
.版本 2

.DLL命令 GetWindowTextA, 整数型, "user32", "GetWindowTextA", 公开, 窗口_取标题 取得一个窗体的标题(caption)文字,或者一个控件的内容(在vb里使用:使用vb窗体或控件的caption或text属性) 复制到lpString的字串长度;不包括空中止字符。
.参数 hwnd, 整数型, , 窗口句柄 欲获取文字的那个窗口的句柄
.参数 lpString, 文本型, 传址, 缓冲区 预定义的一个缓冲区,至少有cch+1个字符大小;随同窗口文字载入
.参数 cch, 整数型, , 缓冲尺寸 lp缓冲区的长度;

SetWindowTextA
.版本 2

.DLL命令 SetWindowTextA, 整数型, "user32", "SetWindowTextA", 公开, 窗口_置标题 设置窗口的标题文字或控件的内容(在vb里使用:针对vb窗体,应使用caption或text属性) 非零表示成功,零表示失败。
.参数 hwnd, 整数型, , 要设置文字的窗口的句柄
.参数 lpString, 文本型, , 要设到hwnd窗口中的文字;

模块源码 窗口_取标题

.版本 2

.子程序 窗口_取标题, 文本型, 公开, 成功返回窗口标题
.参数 窗口句柄, 整数型
.局部变量 局_缓冲区大小, 整数型
.局部变量 局_缓冲区, 文本型

局_缓冲区大小 = GetWindowTextLength (窗口句柄) + 1
局_缓冲区 = 取空白文本 (局_缓冲区大小)
GetWindowTextA (窗口句柄, 局_缓冲区, 局_缓冲区大小)
返回 (局_缓冲区)


发布日期:

所属分类: 易语言 标签: