易语言PeekMessage检查消息队列

检查消息队列PeekMessageA

.版本 2
 
.DLL命令 检查消息队列_, 整数型, "user32.dll", "PeekMessageA"
    .参数 消息格式, 消息_, , lpMsg
    .参数 窗口句柄, 整数型, , hWnd
    .参数 消息最小过滤值, 整数型, , wMsgFilterMin
    .参数 消息最大过滤值, 整数型, , wMsgFilterMax
    .参数 删除消息, 整数型, , wRemoveMsg,是否取得消息后,从消息队列中删除该消息

等待消息WaitMessage

.版本 2
 
.DLL命令 等待消息_, 整数型, "user32.dll", "WaitMessage"

注册热键RegisterHotKey

.版本 2
 
.DLL命令 注册热键_, 整数型, "user32.dll", "RegisterHotKey"
    .参数 窗口句柄, 整数型, , hWnd
    .参数 热键id, 整数型, , id
    .参数 功能键, 整数型, , fsModifiers
    .参数 主热键, 整数型, , vk

取消热键注册UnregisterHotKey

.版本 2
 
.DLL命令 取消热键注册_, 整数型, "user32.dll", "UnregisterHotKey"
    .参数 窗口句柄, 整数型
    .参数 热键id, 整数型

等待消息WaitMessage

.版本 2
 
.DLL命令 等待消息_, 整数型, "user32.dll", "WaitMessage"

自定义数据类型msg

.版本 2
 
.数据类型 消息_, , Msg
    .成员 窗口句柄, 整数型, , , hWnd
    .成员 消息号, 整数型, , , Message
    .成员 附加参数1, 整数型, , , wParam
    .成员 附加参数2, 整数型, , , lParam
    .成员 发送时间, 整数型, , , time
    .成员 光标横坐标, 整数型, , , x
    .成员 光标纵坐标, 整数型, , , y

常量值

.版本 2
 
.常量 MOD_ALT, "1"
.常量 MOD_CONTROL, "2"
.常量 MOD_SHIFT, "4"
.常量 PM_REMOVE, "1"
.常量 WM_HOTKEY, "786"

主程序调用

设置一个程序集变量:程序集_标志位,类型:逻辑型

.版本 2

.子程序 _按钮_检查消息队列_被单击

程序集_标志位 = 假
注册热键_ (取窗口句柄 (), 0, #MOD_CONTROL, #F键)
标签_提示.标题 = “按下CTRL+F键最小化窗口”
子程序_等待消息 ()

.子程序 子程序_等待消息
.局部变量 局部_消息结构, 消息_

.判断循环首 (取反 (程序集_标志位))
等待消息_ ()
.如果真 (检查消息队列_ (局部_消息结构, 取窗口句柄 (), #WM_HOTKEY, #WM_HOTKEY, #PM_REMOVE) ≠ 0)
.判断开始 (_启动窗口.位置 = 0)
_启动窗口.位置 = 2
.默认
_启动窗口.位置 = 0
.判断结束

.如果真结束
处理事件 ()
.判断循环尾 ()

.子程序 __启动窗口_可否被关闭, 逻辑型

程序集_标志位 = 真
取消热键注册_ (取窗口句柄 (), 0)


发布日期:

所属分类: 后端 标签:  


下一篇:

没有了,已经是最新文章