易语言API模块制作取system32目录和取Windows目录

GetSystemDirectory

.版本 2

.DLL命令 GetSystemDirectoryA, 整数型, "kernel32", "GetSystemDirectoryA", , 目录_取system32目录 这个函数能取得Windows系统目录(System目录)的完整路径名。
.参数 缓冲区, 文本型, , 用于装载系统目录路径名的一个字串缓冲区。它应事先初始化成nSize+1个字符的长度。通常至少要为这个缓冲区分配MAX_PATH个字符的长度
.参数 缓冲区长度, 整数型, , lpBuffer字串的最大长度;255

GetWindowsDirectory

.版本 2

.DLL命令 GetWindowsDirectoryA, 整数型, "kernel32", "GetWindowsDirectoryA", , 目录_取Windows目录 这个函数能获取Windows目录的完整路径名。
.参数 缓冲区, 文本型, , 指定一个字串缓冲区,用于装载Windows目录名。除非是根目录,否则目录中不会有一个中止用的“\”字符
.参数 尺寸, 整数型, , lpBuffer字串的最大长度;

视频教程源码

目录_取system32目录
.版本 2

.子程序 目录_取system32目录, 文本型, 公开, 返回:比如c:\WINDOWS\system32\
.局部变量 j_text, 文本型

j_text = 取空白文本 (255)
GetSystemDirectoryA (j_text, 255)
.如果真 (取文本右边 (j_text, 1) ≠ “\”)
j_text = j_text + “\”
.如果真结束
返回 (j_text)
目录_取Windows目录
.版本 2

.子程序 目录_取Windows目录, 文本型, 公开, 返回:比如c:\WINDOWS\
.局部变量 j_text, 文本型

j_text = 取空白文本 (255)
GetWindowsDirectoryA (j_text, 255)
.如果真 (取文本右边 (j_text, 1) ≠ “\”)
j_text = j_text + “\”
.如果真结束
返回 (j_text)


发布日期:

所属分类: 易语言 标签: