511遇见易语言多线程大漠多线程-19多线程启动方式许可证显示线程信息

.版本 2
.支持库 EThread

.子程序 子程序1
.参数 参数
.局部变量 n

编辑框2.内容 = “正在启动线程” + 到文本 (参数)
许可证1 = 创建进入许可证 ()
进入许可区 (许可证1)
.判断开始 (参数 = 1)
标签1.文本颜色 = #红色
标签1.标题 = “线程1已经启动”
.循环判断首 ()
程序_延时 (5000, )
n = n + 1
编辑框1.加入文本 (到文本 (n) + “我是线程1|” + #换行符)
编辑框2.文本颜色 = #红色
编辑框2.内容 = “线程” + 到文本 (参数) + “正在运行第 ” + 到文本 (n) + “ 次”
处理事件 ()
.循环判断尾 (n ≠ 10)
.默认

.判断结束
退出许可区 (许可证1)

许可证2 = 创建进入许可证 ()
进入许可区 (许可证2)
.判断开始 (参数 = 2)
标签2.文本颜色 = #蓝色
标签2.标题 = “线程2已经启动”
.循环判断首 ()
程序_延时 (5000, )
n = n + 1
编辑框1.加入文本 (“ #” + 到文本 (n) + “我是线程2” + #换行符)
编辑框2.文本颜色 = #红色
编辑框2.内容 = “线程” + 到文本 (参数) + “正在运行第 ” + 到文本 (n) + “ 次”
处理事件 ()
.循环判断尾 (n ≠ 10)

.默认

.判断结束
退出许可区 (许可证2)

.子程序 子程序2
.参数 参数
.局部变量 n

编辑框2.内容 = “正在启动线程” + 到文本 (参数)
.判断开始 (参数 = 1)
标签1.文本颜色 = #红色
标签1.标题 = “线程1已经启动”
.判断 (参数 = 2)
标签2.文本颜色 = #蓝色
标签2.标题 = “线程2已经启动”

.默认

.判断结束

进入许可区 (许可证)
.循环判断首 ()
程序_延时 (5000, )
n = n + 1
编辑框1.加入文本 (到文本 (n) + “我是线程” + 到文本 (参数) + #换行符)
编辑框2.文本颜色 = #红色
编辑框2.内容 = “线程” + 到文本 (参数) + “正在运行第 ” + 到文本 (n) + “ 次”
处理事件 ()
.循环判断尾 (n ≠ 5)
退出许可区 (许可证)

.子程序 _按钮_关闭线程4_被单击
.局部变量 i, 整数型

清除数组 (thwnd)
.计次循环首 (2, i)
加入成员 (thwnd, 线程_启动_句柄 (&子程序2, i, ))
程序_延时 (2000, )
.计次循环尾 ()


发布日期:

所属分类: 易语言 标签: