第10课易语言大漠一键登录输入账号密码

1、GetWords
通过dm.GetWords识别这个范围内所有满足条件的词组. 比较适合用在未知文字的情况下,进行不定识别,因为我们事先不知道账号输入框里是否有字符,有的登录后会记忆,有的不记忆,如果不记忆的话,可以直接输入字符串,这里是按照加入账号输入框里有上次登录的信息的。如果识别识别,直接调用退格键循环删除一下字符,这样更简单。

s=dml.GetWords (323, 212, 488, 238, “160f09-000000”, 1)

2、GetWordResultCount
在使用GetWords进行词组识别以后,可以用此接口进行识别词组数量的计算.

count = dm.GetWordResultCount (s)

3、GetWordResultStr

函数简介:
在使用GetWords进行词组识别以后,可以用此接口进行识别各个词组的内容
函数原型:
string GetWordResultStr(str,index)
参数定义:
str 字符串: GetWords的返回值
index 整形数: 表示第几个词组
返回值:
字符串:
返回的第index个词组内容
示例:
s = dm.GetWords(0,0,2000,2000,"000000-000000",1.0)
count = dm.GetWordResultCount(s)
index = 0
Do While index < count
    word = dm.GetWordResultStr(s,index)
    MessageBox word 
    index = index + 1 
Loop

4、SendString2
我们通过dm.sendstring2向账号和密码框发送账号和密码,也可以尝试SendString,如果两个都被游戏屏蔽了,那么只能模拟键盘输入账号密码。

函数简介:
向指定窗口发送文本数据
函数原型:
long SendString2(hwnd,str) 
参数定义:
hwnd 整形数: 指定的窗口句柄
 
str 字符串: 发送的文本数据
返回值:
整形数:
0: 失败
1: 成功
示例:
 
dm.SendString2 hwnd,"我是来测试的" 
 
注: 此接口为老的SendString,如果新的SendString不能输入,可以尝试此接口.

5、教程源码

.版本 2
.支持库 spec
 
.子程序 输入账号密码
.局部变量 word, 文本型
.局部变量 w_array, 文本型, , "0"
.局部变量 i, 整数型
 
i = 0
.判断循环首 (i = 0)
    延迟 (time)
    word = dm.FindStrFastE (491, 287, 547, 308, “记住账号”, “ffff00-000000”, 1)
    w_array = 分割文本 (word, “|”, )
    .如果 (到整数 (w_array [1])0)
        dm.MoveTo (到整数 (w_array [2])18, 到整数 (w_array [3])65)
        延迟 (time)
        dm.LeftClick ()
        延迟 (time)
        .计次循环首 (50, )
            dm.KeyPress (8)
        .计次循环尾 ()
        i = 1
 
    .否则
 
    .如果结束
    处理事件 ()
.判断循环尾 ()
' 输入账号
dm.SendString2 (hwnd, 账号)
延迟 (time)
dm.KeyPress (13)
延迟 (time)
dm.SendString2 (hwnd, 密码)
延迟 (time)
dm.KeyPress (13)

发布日期:

所属分类: 易语言 标签: