511遇见易语言软件本地注册验证-18-机器特征字_QQ_限制时间_反算时间

机器特征字_QQ_限制时间_反算时间源码:

.版本 2
 
.子程序 注册码_机器特征字_QQ_限制时间_反算T, 日期时间型, , 返回客户注册的时间
.参数 参_注册码, 文本型
.局部变量 代码, 文本型
.局部变量 text, 文本型, , "0"
.局部变量 b, 文本型, , , 就是生成的注册码
.局部变量 n, 整数型
.局部变量 还原文本, 文本型, , , 就是生成中的T
.局部变量 时间文本, 文本型
 
代码 = 参_注册码
重定义数组 (text,, 取文本长度 (代码) ÷ 2)
.计次循环首 (取文本长度 (代码) ÷ 2, n)
    text [n] = 取文本左边 (代码, 2)
    代码 = 取文本右边 (代码, 取文本长度 (代码)2)
    b = b + text [n]
    ' 调试输出 (b)
    还原文本 = 字符 (到数值 (text [n])) + 还原文本
.计次循环尾 ()
时间文本 = 取文本左边 (还原文本, 寻找文本 (还原文本, “Y”, , 真) - 1)
' 取出来之后,1、先进制转换
时间文本 = 进制转换 (时间文本, 16, 10)
' 2、再右移 4
时间文本 = 到文本 (右移 (到数值 (时间文本), 4))
' 3、转换为时间
返回 (到时间 (时间文本))


发布日期:

所属分类: 易语言 标签:   


下一篇:

没有了,已经是最新文章