易语言乐玩插件FindPicEx找图扩展找多图

乐玩插件FindPicEx模块源码:

.版本 2
 
.子程序 FindPicEx, 文本型, 公开
.参数 x1
.参数 y1
.参数 x2
.参数 y2
.参数 pic_name, 文本型
.参数 delta_color, 文本型
.参数 sim, 小数型
.参数 dir
 
返回 (obj.文本方法 (“FindPicEx”, x1, y1, x2, y2, pic_name, delta_color, sim, dir))

乐玩插件FindPicEx调用源码:

.版本 2
.支持库 spec
 
.子程序 _按钮12_被单击, , , FindPicEX
.局部变量 ret, 文本型
.局部变量 ss, 文本型, , "0"
.局部变量 sss, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 id, 整数型
.局部变量 x
.局部变量 y
 
ret = l.FindPicEx (0, 0, 2000, 2000,2.bmp|1.bmp, “000000”, 0.95, 0)
调试输出 (ret)
' “1,602,5|2,754,175”
.如果真 (取文本长度 (ret) > 0)
    ss = 分割文本 (ret, “|”, )
    .计次循环首 (取数组成员数 (ss), i)
        sss = 分割文本 (ss [i], “,”, )
        id = 到整数 (sss [1])
        x = 到整数 (sss [2])
        y = 到整数 (sss [3])
        延时 (100)
        l.MoveTo (x, y)
        延时 (100)
        l.LeftDoubleClick ()
        延时 (100)
    .计次循环尾 ()

教程下载:

链接:https://pan.baidu.com/s/1Z-GwQ84X7iccpK3NngsPZQ

提取码:加QQ群:521068947 群文件下载


发布日期:

所属分类: 易语言 标签: