易语言PathIsSameRootA判断路径是否同一盘符

是否为相同盘符PathIsSameRootA

.版本 2
 
.DLL命令 是否为相同盘符_, 逻辑型, "shlwapi.dll", "PathIsSameRootA"
    .参数 路径文本1, 文本型, , pszPath1
    .参数 路径文本2, 文本型, , pszPath2

易语言调用

编辑框_路径1.内容=“m:\somefile.txt”
编辑框_路径2.内容=“m:\text\somefile.txt”

.版本 2
 
.子程序 _按钮_是否为相同盘符_被单击
 
.判断开始 (是否为相同盘符_ (编辑框_路径1.内容, 编辑框_路径2.内容) = 真)
    编辑框_检查结果.内容 = 编辑框_路径1.内容 + “和” + 编辑框_路径2.内容 + “同一盘符”
.默认
    编辑框_检查结果.内容 = 编辑框_路径1.内容 + “和” + 编辑框_路径2.内容 + “不同盘符”
.判断结束

发布日期:

所属分类: 易语言 标签: