大漠多账号循环登录任务自动切换模板-4一键启动游戏

本课视频功能源码

.版本 2

.子程序 监控反馈
.参数 事件, 文本型

编辑框1.加入文本 (取格式化时间 (取现行时间 ()) + “ --- ” + 事件 + #换行符)

.子程序 取格式化时间, 文本型
.参数 现行时间, 日期时间型
.局部变量 局_年, 文本型
.局部变量 局_月, 文本型
.局部变量 局_日, 文本型
.局部变量 局_时, 文本型
.局部变量 局_分, 文本型
.局部变量 局_秒, 文本型

局_年 = 到文本 (取年份 (现行时间))
局_月 = 到文本 (取月份 (现行时间))
局_日 = 到文本 (取日 (现行时间))
局_时 = 到文本 (取小时 (现行时间))
局_分 = 到文本 (取分钟 (现行时间))
局_秒 = 到文本 (取秒 (现行时间))

.如果真 (取文本长度 (局_月) < 2)
局_月 = “0” + 局_月
.如果真结束
.如果真 (取文本长度 (局_日) < 2)
局_日 = “0” + 局_日
.如果真结束
.如果真 (取文本长度 (局_时) < 2)
局_时 = “0” + 局_时
.如果真结束
.如果真 (取文本长度 (局_分) < 2)
局_分 = “0” + 局_分
.如果真结束
.如果真 (取文本长度 (局_秒) < 2)
局_秒 = “0” + 局_秒
.如果真结束

返回 (局_年 + “-” + 局_月 + “-” + 局_日 + “ ” + 局_时 + “:” + 局_分 + “:” + 局_秒)

.子程序 _按钮_启动游戏_被单击, , , 启动游戏
.局部变量 游戏路径, 文本型

游戏路径 = “D:\游戏\剑侠\剑侠情缘网络版\gamefree.exe”
' dm.RunApp (游戏路径, 1)
' 进程创建
改变目录 (取文本左边 (游戏路径, 倒找文本 (游戏路径, “\”, , 假)))

.判断开始 (运行 (游戏路径, 假, ) = 假)
监控反馈 (“启动游戏失败”)
返回 ()
.默认
监控反馈 (“启动游戏成功”)


发布日期:

所属分类: 易语言 标签: