大漠多账号循环登录任务自动切换模板-5大漠绑定游戏

视频教程源码:

.版本 2
.支持库 EThread

' 获取游戏窗口句柄
句柄 = dm.EnumWindowByProcess (“gamefree.exe”, “剑侠情缘·网络版”, “Sword3 Class”, 1 + 2)
.如果真 (句柄 = “”)
监控反馈 (“获取句柄失败”)
返回 ()
.如果真结束

监控反馈 (“窗口句柄:” + 句柄)
hwnd = 到整数 (句柄)
.判断开始 (按钮_开始.标题 = “开始”)
.判断开始 (运行状态 = 0)
按钮_开始.标题 = “停止”
按钮_开始.禁止 = 真
.判断开始 (hwnd > 0)
' 激活窗口
dm.SetWindowState (hwnd, 1)
.判断开始 (dm.BindWindow (hwnd, “dx”, “dx2”, “windows”, 0) = 1)
监控反馈 (“窗口绑定成功”)
超级延时 (400, )
运行状态 = 1
.判断开始 (启动线程 (&主线程, , thwnd))
按钮_开始.禁止 = 假

.默认
状态 = 真
.判断结束

.默认
监控反馈 (“窗口绑定失败!”)
状态 = 真
.判断结束

.默认
监控反馈 (“先获取句柄!”)
状态 = 真
.判断结束
.默认
监控反馈 (“不要重复启动!”)

.判断结束
.如果 (状态 = 真)
运行状态 = 1
停止()
.否则
.如果结束

.判断 (按钮_开始.标题 = “停止”)
停止()


发布日期:

所属分类: 易语言 标签: