易语言取指定文本模块封装

.版本 2

.子程序 取指定文本, 文本型, 公开
.参数 源文本, 文本型
.参数 左边文本, 文本型, 可空, 不提供则从首部开始
.参数 右边文本, 文本型, 可空, 不提供则截止到尾部
.参数 是否区分大小写, 逻辑型, 可空, 为真区分,默认为假
.局部变量 起始位置, 整数型
.局部变量 截止位置, 整数型
.局部变量 截取长度, 整数型

.如果真 (是否为空 (是否区分大小写))
是否区分大小写 = 假
.如果真结束
.如果 (是否为空 (左边文本) 或 左边文本 = “”)
起始位置 = 1
.否则
起始位置 = 寻找文本 (源文本, 左边文本, , 是否区分大小写 = 假)
.如果结束
.如果真 (起始位置 < 0)
返回 (“”)
.如果真结束
起始位置 = 起始位置 + 取文本长度 (左边文本)
.如果 (是否为空 (右边文本) 或 右边文本 = “”)
截止位置 = 取文本长度 (源文本) + 1
.否则
截止位置 = 寻找文本 (源文本, 右边文本, 起始位置, 是否区分大小写 = 假)
.如果结束
.如果真 (截止位置 < 0)
返回 (“”)
.如果真结束
截取长度 = 截止位置 - 起始位置
返回 (取文本中间 (源文本, 起始位置, 截取长度))


发布日期:

所属分类: 易语言 标签: